Degraded performance

Incident Report for TimelyGrader

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 10:35 PDT

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 10:29 PDT

Investigating

We are currently investigation potential errors on processing.
Posted Mar 30, 2026 - 10:24 PDT
This incident affected: TimelyGrader Self Serve Platform and TimelyGrader API Instances.